<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, viewport-fit=contain">
<title>Nittany Lions In The NFL: Week 17 Roundup | Onward State</title>

<meta name="description" content="Trace McSorley&#039;s NFL debut headlines this week&#039;s edition of Nittany Lions in the NFL." />
<link rel="canonical" href="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Nittany Lions In The NFL: Week 17 Roundup" />
<meta property="og:description" content="Trace McSorley&#039;s NFL debut headlines this week&#039;s edition of Nittany Lions in the NFL." />
<meta property="og:url" content="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" />
<meta property="og:site_name" content="Onward State" />
<meta property="article:publisher" content="https://www.facebook.com/OnwardState/" />
<meta property="article:section" content="Football" />
<meta property="article:published_time" content="2019-12-30T14:57:00-05:00" />
<meta property="article:modified_time" content="2019-12-30T14:58:18-05:00" />
<meta property="og:updated_time" content="2019-12-30T14:58:18-05:00" />
<meta property="fb:app_id" content="262823580468325" />
<meta property="og:image" content="https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2-1697x1160.jpg" />
<meta property="og:image:secure_url" content="https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2-1697x1160.jpg" />
<meta property="og:image:width" content="1697" />
<meta property="og:image:height" content="1160" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Trace McSorley&#039;s NFL debut headlines this week&#039;s edition of Nittany Lions in the NFL." />
<meta name="twitter:title" content="Nittany Lions In The NFL: Week 17 Roundup | Onward State" />
<meta name="twitter:site" content="@onwardstate" />
<meta name="twitter:image" content="https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=4864%2C3325&#038;ssl=1" />
<meta name="twitter:creator" content="@gabeangieri" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://onwardstate.com/#website","url":"https://onwardstate.com/","name":"Onward State","potentialAction":{"@type":"SearchAction","target":"https://onwardstate.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/#primaryimage","url":"https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=4864%2C3325&ssl=1","width":4864,"height":3325},{"@type":"WebPage","@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/#webpage","url":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/","inLanguage":"en-US","name":"Nittany Lions In The NFL: Week 17 Roundup | Onward State","isPartOf":{"@id":"https://onwardstate.com/#website"},"primaryImageOfPage":{"@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/#primaryimage"},"datePublished":"2019-12-30T14:57:00-05:00","dateModified":"2019-12-30T14:58:18-05:00","author":{"@id":"https://onwardstate.com/#/schema/person/3b6bb30396c494c9b2a9d4b3cf0d9aae"},"description":"Trace McSorley's NFL debut headlines this week's edition of Nittany Lions in the NFL.","breadcrumb":{"@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://onwardstate.com/category/topics/","url":"https://onwardstate.com/category/topics/","name":"Topics"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://onwardstate.com/category/topics/football-topics/","url":"https://onwardstate.com/category/topics/football-topics/","name":"Football"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/","url":"https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/","name":"Nittany Lions In The NFL: Week 17 Roundup"}}]},{"@type":["Person"],"@id":"https://onwardstate.com/#/schema/person/3b6bb30396c494c9b2a9d4b3cf0d9aae","name":"Gabe Angieri","description":"Gabe Angieri is a freshman majoring in broadcast journalism. He grew up in Lindenhurst, NY and has had the absolute misfortune of rooting for the Jets, Mets, and Knicks. If you want to see his rants on all of his teams follow him on twitter @gabeangieri","sameAs":["https://twitter.com/gabeangieri"]}]}</script>

<link rel='dns-prefetch' href='//a.opmnstr.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//images.onwardstate.com' />
<link rel="alternate" type="application/rss+xml" title="Onward State &raquo; Feed" href="https://onwardstate.com/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/onwardstate.com\/wp\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mp-theme-css' href='https://onwardstate.com//wp-content/plugins/memberpress/css/ui/theme.css?ver=1.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://onwardstate.com/wp/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css' href='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/css/slick.css?ver=20170328' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-min-css' href='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/css/font-awesome.min.css?ver=20170328' type='text/css' media='all' />
<link rel='stylesheet' id='tooltipster-min-css-css' href='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/css/tooltipster.min.css?ver=20170328' type='text/css' media='all' />
<link rel='stylesheet' id='logo-carousel-pro-style-css' href='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/css/style.css?ver=20170328' type='text/css' media='all' />
<link rel='stylesheet' id='logo-carousel-pro-responsive-css' href='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/css/responsive.css?ver=20170328' type='text/css' media='all' />
<link rel='stylesheet' id='unipress-api-css' href='https://onwardstate.com//wp-content/plugins/unipress-api//css/unipress.css?ver=1.18.4' type='text/css' media='all' />
<link rel='stylesheet' id='terminal-app-css' href='https://onwardstate.com//wp-content/themes/terminal/client/build/index.css?ver=3.96' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-css' href='https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/assets/css/easy-social-share-buttons.min.css?ver=6.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-display-methods-css' href='https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/assets/css/essb-display-methods.min.css?ver=6.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='essb-social-followers-counter-css' href='https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/lib/modules/social-followers-counter/assets/css/essb-followers-counter.min.css?ver=6.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://onwardstate.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://onwardstate.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
/* ]]> */
</script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/ad-layers/js/ad-layers-dfp.js?ver=0.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
/* ]]> */
</script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/ad-layers/js/ad-layers.js?ver=0.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/onwardstate.com\/wp\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/unipress-api//js/unipress.js?ver=1.18.4'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/themes/terminal/client/build/index.bundle.js?ver=3.96'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js'></script>
<link rel='https://api.w.org/' href='https://onwardstate.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://onwardstate.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://onwardstate.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F&#038;format=xml" />
<style>.lazyload {
	display: block;
}

.lazyload,
        .lazyloading {
			opacity: 0;
		}
		
		
		.lazyloaded {
			opacity: 1;
			transition: opacity 300ms;
		}</style><noscript><style>.lazyload { display: none; }</style></noscript>

<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0" />
<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/onwardstate.com\/2019\/12\/30\/nittany-lions-in-the-nfl-week-17-roundup\/"},"headline":"Nittany Lions In The NFL: Week 17 Roundup","url":"http:\/\/onwardstate.com\/2019\/12\/30\/nittany-lions-in-the-nfl-week-17-roundup\/","thumbnailUrl":"https:\/\/i0.wp.com\/images.onwardstate.com\/uploads\/2018\/11\/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=500%2C342&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i0.wp.com\/images.onwardstate.com\/uploads\/2018\/11\/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=500%2C342&ssl=1"},"dateCreated":"2019-12-30T14:57:00Z","datePublished":"2019-12-30T14:57:00Z","dateModified":"2019-12-30T14:57:00Z","articleSection":"Football","author":[{"@type":"Person","name":"Gabe Angieri"}],"creator":["Gabe Angieri"],"keywords":["topics","football","gabeangieri","mattdisanto"],"publisher":{"@type":"Organization","name":"Onward State","logo":{"@type":"ImageObject","url":""}}}
	</script>

<meta name="og:referenced" content="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><style> #wp-admin-bar-classic-edit > a.ab-item::before { content: "\f464"; } </style> <script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
<script type="text/javascript">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</script>
<style type="text/css">.terminal-body-font { font-family: Georgia, Cambria, Times New Roman, Times, serif;  } .terminal-body-font svg { fill: ; } .terminal-cta-button-font { text-transform: lowercase; font-style: italic; color: #ffffff; font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-cta-button-font svg { fill: #ffffff; } .terminal-cta-tagline-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-cta-tagline-font svg { fill: ; } .terminal-nav-font, .terminal-nav-font a	 { color: #ffffff; font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-nav-font, .terminal-nav-font a	 svg { fill: #ffffff; } .terminal-headline-featured-font, .terminal-headline-featured-font a { font-family: Georgia, Cambria, Times New Roman, Times, serif;  } .terminal-headline-featured-font, .terminal-headline-featured-font a svg { fill: ; } .terminal-headline-font, .terminal-headline-font a { color: #222222; font-family: Georgia, Cambria, Times New Roman, Times, serif;  } .terminal-headline-font, .terminal-headline-font a svg { fill: #222222; } .terminal-index-meta-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-index-meta-font svg { fill: ; } .terminal-header-font, .terminal-header-font a, .terminal-header-font a:hover { text-transform: uppercase; color: #ffffff; font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-header-font, .terminal-header-font a, .terminal-header-font a:hover svg { fill: #ffffff; } .terminal-share-button-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-share-button-font svg { fill: ; } .terminal-sidebar-body-font { font-family: Georgia, Cambria, Times New Roman, Times, serif;  } .terminal-sidebar-body-font svg { fill: ; } .terminal-sidebar-header-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-sidebar-header-font svg { fill: ; } .terminal-single-meta-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-single-meta-font svg { fill: ; } body, .terminal-utility-font { font-family: Trebuchet MS, Helvetica, sans-serif;  } body, .terminal-utility-font svg { fill: ; } .terminal-card-title { font-family: Trebuchet MS, Helvetica, sans-serif;  } .terminal-card-title svg { fill: ; } .terminal-footer-font { font-family: inherit;  } .terminal-footer-font svg { fill: ; } .terminal-excerpt-font { font-family: inherit;  } .terminal-excerpt-font svg { fill: ; } 			.terminal-nav-bar, .terminal-nav-bar-inside-more {
				background-color: #0c1e4c;
			}
		body { border-top: 3px solid #9dc1fd; } .terminal-signup { background-color: #9dc1fd; } @media (max-width: 800px) { body { border-top: #9dc1fd solid 3px; } } 			.terminal-header-container, .wp-polls .pollbar {
				background-color: #9DC1FD;
			}

			.terminal-footer {
				background-color: #9DC1FD;
									border-bottom: 2px solid #0c1e4c							}

		.single .terminal-post-card, .single .terminal-card {
						}
	
		.terminal-post-card, .terminal-card {
				background-color: #ffffff;			}

			.terminal-header {
				background-color: #0c1e4c;			}

			.terminal-footer-leaderboard {
				background-color: #f8f8f8;
			}

			.terminal-featured-section, .terminal-hero-container .terminal-hero-widget, .terminal-breakout-container .terminal-hero-widget, #terminal-search, .terminal-card-fade {
				background-color: #efefef;			}

			.terminal-primary-sidebar .terminal-sidebar-card {
				background-color: #ffffff;			}

			.terminal-sidebar-card {
				background-color: #ffffff;			}

			.terminal-byline {
				background-color: #ffffff;
				padding: 5px;
			}

			.terminal-header-leaderboard {
				background-color: #f8f8f8;
			}
			figure.wp-caption, .terminal-breadcrumbs, .terminal-card-title {
				background-color: #f2f2f2;
			}

			.terminal-search-form-more .terminal-search-form-reset-link a {
				border: 1px solid #f2f2f2;
			}
		</style><meta name="smartbanner:enabled-platforms" content="ios, android">
<meta name="smartbanner:title" content="Onward State for iOS">
<meta name="smartbanner:author" content="Onward State">
<meta name="smartbanner:price" content="Free">
<meta name="smartbanner:price-suffix-apple" content="- Updated">
<meta name="smartbanner:price-suffix-google" content="- Updated">
<meta name="smartbanner:icon-apple" content="https://i0.wp.com/images.onwardstate.com/uploads/2018/07/690x0w.jpg?fit=50%2C50&amp;ssl=1">
<meta name="smartbanner:icon-google" content="https://i0.wp.com/images.onwardstate.com/uploads/2018/07/690x0w.jpg?fit=50%2C50&amp;ssl=1">
<meta name="smartbanner:button" content="App Store">
<meta name="smartbanner:button-url-apple" content="https://itunes.apple.com/us/app/onwardstate/id857907771">
<meta name="smartbanner:button-url-google" content="https://play.google.com/store/apps/details?id=com.onwardstate.portal&amp;hl=en_US">
<style type="text/css">.essb-subscribe-form-content.essb-subscribe-from-design9 { background-color: #ffffff !important;}.essb-subscribe-form-content.essb-subscribe-from-design9, .essb-subscribe-form-content.essb-subscribe-from-design9 h4, .essb-subscribe-form-content.essb-subscribe-from-design9 input.essb-subscribe-form-content-email-field, .essb-subscribe-form-content.essb-subscribe-from-design9 input.essb-subscribe-form-content-name-field { color: #0a0a0a !important;}.essb-subscribe-form-content.essb-subscribe-from-design9 input.submit { background-color: #9dc1fd!important; }.essb-subscribe-form-content.essb-subscribe-from-design9 input.submit:hover { background: #7fa3df!important;}.essb-subscribe9-icon { color: #9dc1fd!important; }.essb_bottombar { background: rgba(255,255,255,.9) !important; }.essb_bottombar .essb_bottombar_inner { max-width: 1080px; margin: 0 auto; padding-left: 0px; padding-right: 0px;}</style>
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/onwardstate.com\/wp\/wp-admin\/admin-ajax.php","essb3_nonce":"ae20b39530","essb3_plugin_url":"https:\/\/onwardstate.com\/\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":true,"essb3_ga_mode":"layers","blog_url":"https:\/\/onwardstate.com\/wp\/","essb3_postfloat_stay":false,"post_id":400520,"bottombar_disappear":"80"};var essbis_settings = {"modules":{"settings":{"moduleHoverActive":1,"activeModules":["settings","buttons","hover"]},"buttons":{"pinterestImageDescription":["titleAttribute","altAttribute","postTitle","mediaLibraryDescription"],"networks":"facebook,twitter,pinterest"},"hover":{"imageSelector":"article .terminal-card-text img, article .terminal-card-image img","minImageHeight":100,"minImageWidth":100,"hoverPanelPosition":"top-left","theme":"flat-small","orientation":"vertical","showOnHome":"1","showOnSingle":"1","showOnPage":"1","showOnBlog":"1","showOnLightbox":"1","alwaysVisible":false,"mobileOnClick":true,"networks":"facebook,twitter,pinterest","theme_mobile":"flat-small"}},"twitteruser":"OnwardState","fbapp":"262823580468325","dontshow":"","buttonSets":[],"themes":[]};</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f8f8f8; }
</style>
<link rel="amphtml" href="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/amp/"><link rel="icon" href="https://i0.wp.com/images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Lion-2.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Lion-2.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Lion-2.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Lion-2.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				@import url('https://fonts.googleapis.com/css?family=Fira+Sans:400');


body .terminal-sidebar-card .textwidget .scquicklinks {
	font-family:'Fira Sans', sans-serif !important;
	margin: 0 -15px 0 -15px;
	padding: 0 15px 15px 15px;
	font-size: 18px;
}

body .terminal-sidebar-card .sidebar-stories {
	margin: -15px 0;
}

body .terminal-sidebar-card .textwidget .scquicklinks:nth-of-type(odd) {
	background: #e5ebf0;
}

.essbfc-container {
	margin-bottom: 0;
}

.essbfc-followers-count {
	font-size: 40px;
}


.terminal-card-title {
	background-color: #b5c6d3 !important;
}

.terminal-post-widget-featured {
	background-color: #ecf0f1;
	padding-bottom: 10px;
	margin-bottom: 10px !important;
}

.sp-lcp-item img {
    max-width: 100%;
    height: auto;
}

.sp-logo-carousel-pro-section {
	margin: 0 15px 15px 15px;
}

.essb_links .essb_force_hide_name .essb_icon {
    margin: 0 auto !important;
		display: block;
}


.essb_links.essb_counter_modern_top_mini .essb_counter {
	margin-top: -21px !important;
}

.scquicklinks span { 
  display: block;
  color: initial;
  margin-top: 5px;
}

.scquicklinks a {
    display: block;
    height: auto;
}

.gfield_checkbox input {
	margin-right: 15px;
}

#div-gpt-ad-OS_football_news_story {
    margin: 0 auto 15px auto;
}

.page-id-384587 .terminal-card .terminal-card-text table {
	font-size: 20px;
	line-height: 50px;
}
			</style>
<script type="text/javascript">var terminal = {"debugMode":false,"inlineAds":{"disabled":false,"enabled":true,"unit":"OS_ROS_instory","noAdID":"317777","adblockLink":"https:\/\/onwardstate.com\/register\/ad-free\/","subscribed":false},"mailchimpUser":"aecf5dcdd25770be2085fa4da","mailchimpList":"03a8d27d61","single":{"author_name":"Gabe Angieri","author_id":27283,"post_categories":[{"name":"Football","slug":"football-topics"}],"post_has_thumbnail":true,"post_title":"Nittany Lions In The NFL: Week 17 Roundup","post_id":400520,"post_type":"post"},"isSearch":false,"parsely":{"enabled":true,"apiKey":"onwardstate.com","apiSecret":"sGJmndQM3FGy8XUyi7pkxMWGCcQTAtkzPf7US3Jn7cg"}}; dataLayer = [{ terminal }];</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-PPN9ZXB');</script>
</head>
<body class="post-template-default single single-post postid-400520 single-format-standard custom-background essbis_site">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PPN9ZXB&noscript=true"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="terminal-header-container">
<div class="terminal-header-inside"><div class="terminal-header-leaderboard"><div id="ad_layers_ad_widget-17" class=terminal-header-section widget_ad_layers_ad_widget covered-target"><div id="div-gpt-ad-OS_Leaderboard_top" class="dfp-ad dfp-OS_Leaderboard_top" data-ad-unit="OS_Leaderboard_top">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_Leaderboard_top"); } );
						}
					</script>
</div></div></div><div class="terminal-logos"><div class="terminal-logo "><a title="Home" href="https://onwardstate.com"><img class="terminal-image" src="https://images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Site-Logo.png" draggable="false" alt="Onward State" /></a></div><div class="terminal-cta terminal-desktop-show"><div class="terminal-cta-tagline terminal-cta-tagline-font"><p>PSU news by<br />
Penn State's student blog</p>
</div><div class="terminal-cta-link"><a href="https://twitter.com/onwardstate"><img class="terminal-cta-image" src="https://i1.wp.com/images.onwardstate.com/uploads/2018/02/twitter-logo-final-1.png?fit=500%2C500&#038;ssl=1" /></a><a href="https://twitter.com/onwardstate" class="terminal-action terminal-cta-button-font">Follow us!</a></div></div></div></div></div>
<div class="terminal-nav-bar">
<div class="terminal-nav-bar-header-container terminal-nav-font">
<div class="menu-header-container"><ul id="terminal-nav-bar-header" class="menu"><li class="terminal-nav-bar-inside-more-link terminal-hidden-no-js"><a href="#"> <svg class="terminal-svg" height="32px" id="Layer_1" style="enable-background:new 0 0 32 32;" version="1.1" viewBox="0 0 32 32" width="32px" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M4,10h24c1.104,0,2-0.896,2-2s-0.896-2-2-2H4C2.896,6,2,6.896,2,8S2.896,10,4,10z M28,14H4c-1.104,0-2,0.896-2,2  s0.896,2,2,2h24c1.104,0,2-0.896,2-2S29.104,14,28,14z M28,22H4c-1.104,0-2,0.896-2,2s0.896,2,2,2h24c1.104,0,2-0.896,2-2  S29.104,22,28,22z" /></svg></a></li><li id="menu-item-293687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293687 terminal-scroll-hide"><a href="https://onwardstate.com/category/news/">News</a></li>
<li id="menu-item-303870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-303870 terminal-scroll-hide"><a href="https://jobs.onwardstate.com">Jobs</a></li>
<li id="menu-item-293690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293690 terminal-scroll-hide"><a href="https://onwardstate.com/about/">About</a></li>
<li id="menu-item-386219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-386219 terminal-scroll-hide"><a href="https://onwardstate.com/penn-state-football-student-ticket-exchange/">Tickets</a></li>
<li class="terminal-nav-bar-logo terminal-desktop-hide terminal-scroll-show"><a href="https://onwardstate.com"><img class="terminal-image" src="https://images.onwardstate.com/uploads/2018/02/cropped-Onward-State-Site-Logo.png" draggable="false" alt="Onward State" /></a></li><li class="terminal-nav-bar-inside-search-link terminal-hidden-no-js"><a href="#">
<svg class="terminal-svg " width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" /></svg></a></li></ul></div> </div>
<div class="terminal-nav-bar-inside-search terminal-nav-font terminal-limit-max-content-width terminal-hidden"><form id="search-form-search-1922261437" role="search" method="get" class="search-form" action="https://onwardstate.com/">
<div class="search-form-field">
<label for="search-1922261437">Search</label>
<input id="search-1922261437" type="search" results=5 autosave="terminal-search-recent" class="search-field" value="" placeholder="Enter Search Here" name="s" />
<input type="submit" class="search-submit" value="Search" />
</div>
</form>
<div class="terminal-example-searches terminal-mobile-hide terminal-alignment-center"><h4>Example Searches</h4><p><a href="https://onwardstate.com/?s=%22Natty+Nittany%22">Natty Nittany</a><br />
<a href="https://onwardstate.com/?s=%22Onward+Debates%22">Onward Debates</a><br />
<a href="https://onwardstate.com/?s=%22Photo+Story%22">Photo Story</a><br />
<a href="https://onwardstate.com/?s=%22Drunk%2C+Sober%2C+High%22">Drunk, Sober, High</a><br />
<a href="https://onwardstate.com/?s=%22Squirrel+Girl%22">Squirrel Girl</a></p>
</div> </div>
<div class="terminal-nav-bar-inside-more terminal-nav-font terminal-hidden"><h2>Topics</h2><div class="menu-topics-container"><ul id="terminal-nav-bar-header-more" class="menu"><li id="menu-item-212922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212922"><a href="https://onwardstate.com/category/topics/athletics-topics/">Athletics</a></li>
<li id="menu-item-212928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212928"><a href="https://onwardstate.com/category/topics/downtown-topics/">Downtown</a></li>
<li id="menu-item-212923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212923"><a href="https://onwardstate.com/category/topics/entertainment-topics/">Entertainment</a></li>
<li id="menu-item-212927" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-212927"><a href="https://onwardstate.com/category/topics/football-topics/">Football</a></li>
<li id="menu-item-277517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277517"><a href="https://onwardstate.com/category/topics/greek-life/">Greek Life</a></li>
<li id="menu-item-212925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212925"><a href="https://onwardstate.com/category/topics/penn-state/">Penn State</a></li>
<li id="menu-item-245881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245881"><a href="https://onwardstate.com/category/press-releases/">Press Releases</a></li>
<li id="menu-item-212924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212924"><a href="https://onwardstate.com/category/topics/sandusky-scandal-topics/">Sandusky Scandal</a></li>
<li id="menu-item-212926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212926"><a href="https://onwardstate.com/category/topics/student-life-topics/">Student Life</a></li>
<li id="menu-item-212921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212921"><a href="https://onwardstate.com/category/topics/thon/">THON</a></li>
</ul></div><h2>More</h2><div class="menu-more-container"><ul id="terminal-nav-bar-header-more-meta" class="menu"><li id="menu-item-350815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350815"><a href="https://onwardstate.com/advertise/">Advertise</a></li>
<li id="menu-item-351206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-351206"><a href="https://onwardstate.com/archives/">Archives</a></li>
<li id="menu-item-293693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293693"><a href="https://onwardstate.com/tips/">Contact</a></li>
<li id="menu-item-351367" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-351367"><a href="https://onwardstate.com/history/">History</a></li>
<li id="menu-item-351365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-351365"><a href="https://onwardstate.com/join-us/">Join Us</a></li>
<li id="menu-item-350803" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350803"><a href="https://onwardstate.com/masthead/">Masthead</a></li>
<li id="menu-item-386220" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-386220"><a href="https://onwardstate.com/newsletter/">Newsletter</a></li>
<li id="menu-item-293695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293695"><a href="https://onwardstate.com/partners/">Partners</a></li>
</ul></div></div></div>
<div id="terminal-search" class="terminal-hidden">
<div class="terminal-header terminal-header-font">
<h2 class="terminal-search-header">
Enter a search term for instant results </h2>
</div>
</div>
<div id="terminal-search" class="terminal-hidden">
<div class="terminal-header terminal-header-font">
<h2 class="terminal-search-header">
Enter a search term for instant results </h2>
</div>
</div><div class="terminal-container">
<article class="terminal-card terminal-post-card terminal-card-double post-400520 post type-post status-publish format-standard has-post-thumbnail hentry category-football-topics" id="terminal-post-400520"><div class="terminal-meta terminal-no-select"><div class="terminal-breadcrumbs terminal-single-meta-font terminal-text-gray terminal-link-gray-light"><span><span><a href="https://onwardstate.com/category/topics/football-topics/">Football</a></span></div></div><h1 class="terminal-header terminal-header-no-background terminal-headline-featured-font">Nittany Lions In The NFL: Week 17 Roundup</h1><div class="terminal-card-image">
<noscript><IMG width="731" height="500" src="https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=731%2C500&amp;ssl=1" class="attachment-terminal-uncut-thumbnail-large size-terminal-uncut-thumbnail-large wp-post-image" alt="" srcset="https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?w=4864&amp;ssl=1 4864w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=848%2C580&amp;ssl=1 848w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=768%2C525&amp;ssl=1 768w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=1697%2C1160&amp;ssl=1 1697w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=50%2C34&amp;ssl=1 50w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=100%2C68&amp;ssl=1 100w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=500%2C342&amp;ssl=1 500w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=731%2C500&amp;ssl=1 731w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=2000%2C1367&amp;ssl=1 2000w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=1083%2C740&amp;ssl=1 1083w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?w=3000&amp;ssl=1 3000w" sizes="(max-width: 731px) 100vw, 731px"></noscript>
<img width="731" height="500" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="attachment-terminal-uncut-thumbnail-large size-terminal-uncut-thumbnail-large wp-post-image lazyload" alt="" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 731w" sizes="(max-width: 731px) 100vw, 731px" data-srcset="https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?w=4864&amp;ssl=1 4864w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=848%2C580&amp;ssl=1 848w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=768%2C525&amp;ssl=1 768w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=1697%2C1160&amp;ssl=1 1697w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=50%2C34&amp;ssl=1 50w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=100%2C68&amp;ssl=1 100w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=500%2C342&amp;ssl=1 500w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=731%2C500&amp;ssl=1 731w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=2000%2C1367&amp;ssl=1 2000w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?resize=1083%2C740&amp;ssl=1 1083w, https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?w=3000&amp;ssl=1 3000w" data-src="https://i0.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg?fit=731%2C500&amp;ssl=1">
</div><div class="terminal-featured-meta terminal-sidebar-body-font terminal-limit-max-content-width terminal-text-gray-light"><div class="terminal-credit terminal-limit-max-content-width-add-margin"><svg class="terminal-svg" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 16"><path d="m401.94 543.64c-.422-.413-.932-.619-1.528-.619h-1.892l-.431-1.122c-.107-.27-.303-.502-.587-.697-.284-.195-.576-.293-.874-.293h-4.324c-.298 0-.59.098-.874.293-.284.195-.48.428-.587.697l-.431 1.122h-1.892c-.597 0-1.106.206-1.529.619-.422.413-.633.911-.633 1.494v7.395c0 .583.211 1.081.633 1.494.422.413.932.619 1.529.619h11.89c.597 0 1.106-.206 1.528-.619.422-.413.633-.911.633-1.494v-7.395c0-.583-.211-1.081-.633-1.494m-4.801 7.804c-.74.724-1.631 1.085-2.673 1.085-1.042 0-1.932-.362-2.673-1.085-.74-.724-1.111-1.594-1.111-2.612 0-1.018.37-1.889 1.111-2.612.74-.724 1.631-1.085 2.673-1.085 1.042 0 1.932.362 2.673 1.085.74.724 1.111 1.594 1.111 2.612 0 1.018-.37 1.889-1.111 2.612m-2.673-4.989c-.67 0-1.243.232-1.719.697-.476.465-.714 1.025-.714 1.68 0 .655.238 1.215.714 1.68.476.465 1.049.697 1.719.697.67 0 1.243-.232 1.719-.697.476-.465.714-1.025.714-1.68 0-.655-.238-1.215-.714-1.68-.476-.465-1.049-.697-1.719-.697" transform="matrix(.78637 0 0 .78395-302.25-421.36)" /></svg> Matt Sniegowski | Onward State</div></div><div class="terminal-single-meta-font "><div class="terminal-byline terminal-text-gray-light terminal-limit-max-content-width-add-margin"> <div class="terminal-author">
<span>By <a class="terminal-link-gray-light" href="https://onwardstate.com/author/gabeangieri/">Gabe Angieri </a></span>
</div>
<div class="terminal-date">
<a class="terminal-link-gray-light" href="https://onwardstate.com/2019/12/30/">
<abbr class="terminal-date" title="Monday, December 30, 2019 at 9:57am">12/30/19 9:57 am</abbr>
</a>
</div>
</div>
</div><div class="terminal-card-text terminal-body-font terminal-limit-max-content-width">
<input type="hidden" value="" data-essbispostcontainer="" data-essbisposturl="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" data-essbisposttitle="Nittany Lions In The NFL: Week 17 Roundup" data-essbishovercontainer="">
<p>Well, folks. That’s a wrap.</p>
<p>In what was the last week of the NFL regular season, Nittany Lions around the NFL put on a show. Saquon Barkley and Mike Gesicki stayed hot, Amani Oruwariye came up big with an interception, and Trace McSorley made his NFL debut.</p>
<p>Here is a closer look at how Nittany Lions in the NFL ended the regular season:</p>
<div id="div-gpt-ad-OS_football_news_story" class="dfp-ad dfp-OS_football_news_story" data-ad-unit="OS_football_news_story">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_football_news_story"); } );
						}
					</script>
</div>
<h3><strong>Saquon Barkley, New York Giants</strong></h3>
<p>Barkley found the end zone for the third consecutive week in New York’s 34-17 loss to the Eagles on Sunday. He finished the day with 17 rushes for 95 yards and a touchdown. He added three catches for 25 yards as well. </p>
<p>Barkley’s touchdown came late in the third quarter to tie the game up at 17. </p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="gpyc4VsIG1iJSFkCqDQorZ2zBMHx70TmfEw8dRKltP69UvAY"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Saquon took this one 68 yards TO THE HOUSE!! <noscript><IMG src="https://i0.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f633.png?ssl=1" alt="😳" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="😳" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f633.png"><noscript><IMG src="https://i2.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f4a8.png?ssl=1" alt="💨" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="💨" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f4a8.png"> <a href="https://t.co/1RTiOtqO5W">pic.twitter.com/1RTiOtqO5W</a></p>— Onward State (@OnwardState) <a href="https://twitter.com/OnwardState/status/1211432706581696512?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>The running back has looked like a completely different player over the last three games after struggling for much of the season. During this three-game stretch, he has totaled 539 total yards, five touchdowns and has terrorized opposing defenses. </p>
<p>Barkley’s recent resurgence has led to him surpassing 1,000 rushing yards on the season — an astounding feat considering he missed time due to an ankle sprain.</p>
<h3><strong>Mike Gesicki, Miami Dolphins</strong></h3>
<p>Mike Gesicki had a strong performance in Miami’s upset 27-24 win over the Patriots. Quarterback Ryan Fitzpatrick hit Gesicki in the back of the end zone with just 24 seconds remaining to give the Dolphins the game-winning lead.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="YSDilVNq0zWgflkrvtypCBQ9mIpNXjCT74LAooR4bz83AOn7BMRriPwcmKsau1L0Yva5XjKcUbeF8HGqu"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Mike Gesicki gives the Dolphins the lead with just 24 seconds left! <noscript><IMG src="https://i1.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f440.png?ssl=1" alt="👀" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="👀" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f440.png"><noscript><IMG src="https://i0.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f4aa.png?ssl=1" alt="💪" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="💪" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f4aa.png"> <a href="https://t.co/ki8OrUuLXE">pic.twitter.com/ki8OrUuLXE</a></p>— Onward State (@OnwardState) <a href="https://twitter.com/OnwardState/status/1211390798085918721?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>Gesicki ended his season by scoring three touchdowns in the final two games. He took an enormous step forward this season and became a legitimate red-zone weapon for Miami. He increased his reception total by more than 20, his yard total by more than 300, and scored his first five touchdowns of his career this season.</p>
<h3><strong>Allen Robinson, Chicago Bears</strong></h3>
<p>Allen Robinson finished his 2019 campaign in a strong fashion in the Bears’ win over the Vikings. He totaled nine receptions for 71 yards — his highest reception total since week seven.</p>
<p>Robinson finished the year with a career-high 98 catches for 1,147 yards and seven touchdowns in what was his biggest season since 2015.</p>
<h3><strong>Amani Oruwayire, Detroit Lions</strong></h3>
<p>Amani Oruwayire captured his second interception of the season in this week’s loss to the Packers. The pick occurred late in the game on a deep pass attempt by Packers quarterback Aaron Rodgers.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="ltKspWfcLq6Z18JE6SMsV9piHg8T3dm0nNdSqgYvFKvz4nUNkjXhcZxuy27PBfIAatOCeOBQuLEGkA"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Amani Oruwariye went up and GOT IT to pick off Aaron Rodgers! <noscript><IMG src="https://i2.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f64c.png?ssl=1" alt="🙌" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="🙌" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f64c.png"><noscript><IMG src="https://i0.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f60e.png?ssl=1" alt="😎" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="😎" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f60e.png"> <a href="https://t.co/noUuYtPMhK">pic.twitter.com/noUuYtPMhK</a></p>— Onward State (@OnwardState) <a href="https://twitter.com/OnwardState/status/1211395793107767296?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>Oruwayire has certainly made the most of his limited playing time this season. He has accounted for two of the Lions’ seven interceptions this season while playing fewer than 20% of the snaps. He also became the first Lions rookie to capture two or more picks since 2010.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="F6qiWvM0pkrgsX8JhOTSZG1K9ILjUNEB5zw27nobcDRteYaymdxuAPfC3V4lH"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/Lions?src=hash&amp;ref_src=twsrc%5Etfw">#Lions</a> CB Amani Oruwariye (<a href="https://twitter.com/AmaniO?ref_src=twsrc%5Etfw">@AmaniO</a>) becomes the first Lions player since 2010 to record two interceptions in their rookie season. <a href="https://twitter.com/hashtag/OnePride?src=hash&amp;ref_src=twsrc%5Etfw">#OnePride</a> <a href="https://t.co/jxXTKQmCAD">pic.twitter.com/jxXTKQmCAD</a></p>— Detroit Lions PR (@LionsPR) <a href="https://twitter.com/LionsPR/status/1211396619448524800?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<h3><strong>Miles Sanders, Philadelphia Eagles</strong></h3>
<p>Miles Sanders exited Philadelphia’s game in the second quarter with an ankle injury and did not return in the Eagles’ NFC East-clinching win over the Giants. </p>
<p>Before departing with the injury, Sanders was putting together a solid game with nine rushes for 52 yards. He was well on his way to another strong game to continue his recent hot streak.</p>
<p>The latest update on Sanders is that he has a “pretty decent sprain”, as reported by Adam Caplan.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="lOxt4o9rjLFNBwgb1PenSsMC"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">On <a href="https://twitter.com/hashtag/Eagles?src=hash&amp;ref_src=twsrc%5Etfw">#Eagles</a> RB Miles Sanders (right ankle), I'm told it's a "pretty decent sprain." Early word is not high ankle, but testing tomorrow. <br><br>Sanders is known in scouting circles for his toughness, so wouldn't count him out next weekend (especially if testing shows not a high ankle).</p>— Adam Caplan (@caplannfl) <a href="https://twitter.com/caplannfl/status/1211499574512226304?ref_src=twsrc%5Etfw">December 30, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>After the game, Sanders seemed to be in good spirits and danced and celebrated with his playoff-bound teammates in the locker room.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="vAUurjYC"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">This team <noscript><IMG src="https://i1.wp.com/s.w.org/images/core/emoji/12.0.0-1/72x72/1f49a.png?ssl=1" alt="💚" class="wp-smiley" style="height: 1em; max-height: 1em;" data-recalc-dims="1"></noscript><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="💚" class="wp-smiley lazyload" style="height: 1em; max-height: 1em;" data-src="https://s.w.org/images/core/emoji/12.0.0-1/72x72/1f49a.png"><a href="https://twitter.com/hashtag/FlyEaglesFly?src=hash&amp;ref_src=twsrc%5Etfw">#FlyEaglesFly</a> <a href="https://t.co/v5yeSn3OKz">pic.twitter.com/v5yeSn3OKz</a></p>— Philadelphia Eagles (@Eagles) <a href="https://twitter.com/Eagles/status/1211455347531145216?ref_src=twsrc%5Etfw">December 30, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>Sanders finished his season with the 1,327 scrimmage yards — the most among all NFL rookies. He’ll attempt to get healthy for the Eagles’ looming playoff matchup against the Seattle Seahawks, which is set for 4:40 p.m. on Sunday, January 5 at Lincoln Financial Field in Philly.</p>
<h3>
<strong>DaeSean Hamilton</strong>, <strong>Denver Broncos</strong>
</h3>
<p>DaeSean Hamilton had his second consecutive impactful game in Sunday’s win against the Raiders. Hamilton totaled 65 yards for the second straight week, in addition to his five receptions. </p>
<p>Hamilton has significantly benefited from quarterback Drew Lock taking over as the starting quarterback, especially the last two games. The two have displayed some good chemistry recently, which has certainly shown up on the stat sheets.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="urjlTa6SsxCdhXo58gYb9mNpwUOZDIi"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">DaeSean Hamilton had 167 receiving yards in his first 14 games this season.<br><br>He has 103 over his last six quarters.</p>— Aric DiLalla (@AricDiLalla) <a href="https://twitter.com/AricDiLalla/status/1211418327068729345?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>After failing to surpass 60 receiving yards in his first 18 career games, Hamilton has now eclipsed that mark the last two games. Hopefully, his late-season success will translate to next season.</p>
<h3><strong>Trace McSorley, Baltimore Ravens</strong></h3>
<p>Trace McSorley <strong><a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/">finally made his NFL debut</a></strong> in the Ravens’ Week 17 win against the Steelers. McSorley’s appearance was brief but impactful. He carried the ball on third down and picked up a first down.</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="0cpx1zbA46f9fHdhnybkPptGCo2TEkXdwoeruv2JDCSHFnrjELlhu7gGyZOUL8KVl"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Welcome to the NFL, Trace McSorley! <a href="https://t.co/pZvRtZJvyn">pic.twitter.com/pZvRtZJvyn</a></p>— Onward State (@OnwardState) <a href="https://twitter.com/OnwardState/status/1211399374250663944?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<p>It was speculated throughout the week that with starting quarterback Lamar Jackson resting this week, McSorley would see some action at quarterback. However, quarterback Robert Griffin III took all the remaining snaps.</p>
<h3><strong>Other Notables</strong></h3>
<ul>
<li>
<strong>Adrian Amos: </strong>Amos accumulated five tackles for the Packers in their win over the Lions</li>
<li>
<strong>Sean Lee: </strong>Lee was quiet for the Cowboys in their win against the Redskins. He totaled just three tackles.</li>
<li>
<strong>Carl Nassib: </strong>Nassib tallied just three tackles in the Buccaneers’ win against the Falcons</li>
<li>
<strong>Sam Ficken</strong>: Ficken struggled for the Jets in their win against the Bills. He missed two field goals and made two. He also converted his only extra-point attempt.</li>
<li>
<strong>Robbie Gould</strong>: Gould was perfect for the 49ers in their win against the Seahawks. He was 2/2 on field-goal attempts and converted both of his extra points.</li>
<li>
<strong>Jason Cabinda</strong>: Cabinda appeared as a fullback (!!!) for the Lions in their 23-20 loss to the Packers. He was a lead blocker on the goal line on a play that resulted in a touchdown.</li>
</ul>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<span class="KlwLGu5Wte84SL8HRCv3JTjIXYpd0bo5RiO9OUyzJgvmFhPj6ESVqzuWIssrTAHoYhVa7pni6EXUGfcD0AP3gKDecC41mnkxM9fb"><blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Presenting video evidence of Jason Cabinda lining up at f*llback in the NFL: <a href="https://t.co/7emdsGPNXM">pic.twitter.com/7emdsGPNXM</a></p>— Onward State (@OnwardState) <a href="https://twitter.com/OnwardState/status/1211368754694762498?ref_src=twsrc%5Etfw">December 29, 2019</a>
</blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></span>
</div></figure>
<div class="essb_break_scroll"></div>
<div class="terminal-card terminal-adblock-card"><h1>Your ad blocker is on.</h1><p>Please choose an option below.</p>
<div class="terminal-adblock-card-column">Sign up for our e-mail newsletter: <br><div id="terminal-adblock-signup"><form action="https://onwardstate.us12.list-manage.com/subscribe/post"><input type="email" name="EMAIL" placeholder="Email" required" required oninvalid="this.setCustomValidity('Please enter a valid email')" oninput="setCustomValidity('')" /><button type="submit">Sign Up</button></form><div id="terminal-mailchimp-response" style="display:none"></div></div></div>
<div class="terminal-adblock-card-column-or">OR</div>
<div class="terminal-adblock-card-column">Support quality journalism: <br> <a href="https://onwardstate.com/register/ad-free/" class="terminal-adblock-card-subscribe">Purchase a Subscription!</a></div>
<div class="terminal-adblock-card-column"><a href="" class="terminal-adblock-subscribed">Already receiving enough emails?</a>
</div></div><h2 class="terminal-header terminal-header-font">About the Author</h2><div class="terminal-author-snippet terminal-limit-max-content-width">
<img width="500" height="500" src="https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=500%2C500&amp;ssl=1" class="avatar avatar-full photo" alt="" scheme="https" srcset="https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=500%2C500&amp;ssl=1 500w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=1472%2C1472&amp;ssl=1 1472w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=1104%2C1104&amp;ssl=1 1104w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=912%2C912&amp;ssl=1 912w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=550%2C550&amp;ssl=1 550w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=470%2C470&amp;ssl=1 470w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/images.onwardstate.com/uploads/2019/11/Onward-State-Head-Shot.jpg?zoom=2&amp;resize=500%2C500&amp;ssl=1 1000w" sizes="(max-width: 500px) 100vw, 500px" /> <div class="terminal-card-text terminal-single-meta-font">
<h2>
<a class="terminal-link-gray" href="https://onwardstate.com/author/gabeangieri/">Gabe Angieri </a>
</h2>
<p>Gabe Angieri is a freshman majoring in broadcast journalism. He grew up in Lindenhurst, NY and has had the absolute misfortune of rooting for the Jets, Mets, and Knicks. If you want to see his rants on all of his teams follow him on twitter @gabeangieri</p>
</div>
</div>
<div class="terminal-comments-container"><h2 class="terminal-comments-header terminal-header terminal-header-font">Comments</h2><div class="terminal-limit-max-content-width-add-margin"> <div class=" terminal-comments terminal-limit-max-content-width" id="coral_talk_2081003388"></div>
<script src="https://talk.phillypublishing.com/static/embed.js" async onload="
		Coral.talkStream = Coral.Talk.render(document.getElementById('coral_talk_2081003388'), {
			talk: 'https://talk.phillypublishing.com',
			auth_token: '',
		});
	"></script>
</div></div></article><div class="terminal-primary-sidebar"><div id="ad_layers_ad_widget-11" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_ad_layers_ad_widget covered-target"><div id="div-gpt-ad-OS_ROS_Sidebar_Top" class="dfp-ad dfp-OS_ROS_Sidebar_Top" data-ad-unit="OS_ROS_Sidebar_Top">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_ROS_Sidebar_Top"); } );
						}
					</script>
</div></div><div id="search-8" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_search"><div class="terminal-card-title terminal-no-select terminal-sidebar-header-font">Search</div><form id="search-form-search-1009207938" role="search" method="get" class="search-form" action="https://onwardstate.com/">
<div class="search-form-field">
<label for="search-1009207938">Search</label>
<input id="search-1009207938" type="search" results=5 autosave="terminal-search-recent" class="search-field" value="" placeholder="Enter Search Here" name="s" />
<input type="submit" class="search-submit" value="Search" />
</div>
</form>
</div><div id="text-33" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_text"><div class="terminal-card-title terminal-no-select terminal-sidebar-header-font">State College Links</div> <div class="textwidget"><div class="sidebar-stories" style="text-align: left;">
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/bartour/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i2.wp.com/images.onwardstate.com/uploads/2019/01/bar.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i2.wp.com/images.onwardstate.com/uploads/2019/01/bar.png?ssl=1" class=" lazyload"> Bars and Happy Hours</a></div>
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/movies/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i0.wp.com/www.statecollege.com/images/promo/icons/movie.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i0.wp.com/www.statecollege.com/images/promo/icons/movie.png?ssl=1" class=" lazyload"> Movies &#8211; Local theaters and new movies</a></div>
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/apartments/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i1.wp.com/www.statecollege.com/images/promo/icons/apartments.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i1.wp.com/www.statecollege.com/images/promo/icons/apartments.png?ssl=1" class=" lazyload"> Apartments &#8211; Search local apartments</a></div>
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/classifieds/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i0.wp.com/www.statecollege.com/images/promo/icons/classified.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i0.wp.com/www.statecollege.com/images/promo/icons/classified.png?ssl=1" class=" lazyload"> Classifieds &#8211; Buy and sell locally</a></div>
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/auto/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i0.wp.com/www.statecollege.com/images/promo/icons/auto.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i0.wp.com/www.statecollege.com/images/promo/icons/auto.png?ssl=1" class=" lazyload"> Cars / Trucks &#8211; New and used vehicles</a></div>
<div class="scquicklinks"><a class="sidebar-story-title sc" href="http://www.statecollege.com/hotels/" target="_blank" rel="noopener noreferrer"><noscript><IMG src="https://i1.wp.com/www.statecollege.com/images/promo/icons/apartments.png?ssl=1" data-recalc-dims="1"></noscript><br />
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-recalc-dims="1" data-src="https://i1.wp.com/www.statecollege.com/images/promo/icons/apartments.png?ssl=1" class=" lazyload"> Hotels &#8211; In and around Penn State</a></div>
</div>
</div>
</div><div id="ad_layers_ad_widget-12" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_ad_layers_ad_widget covered-target"><div id="div-gpt-ad-OS_ROS_Sidebar_Middle" class="dfp-ad dfp-OS_ROS_Sidebar_Middle" data-ad-unit="OS_ROS_Sidebar_Middle">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_ROS_Sidebar_Middle"); } );
						}
					</script>
</div></div><div id="text-34" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_text"><div class="terminal-card-title terminal-no-select terminal-sidebar-header-font">Follow on another platform</div> <div class="textwidget"><div class="essbfc-container essbfc-col-2 essbfc-template-metro essbfc-nospace essbfc-notextvalue"><ul><li class="essbfc-facebook"><a href="https://www.facebook.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-facebook"></i><span class="essbfc-followers-count">113k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-twitter"><a href="https://www.twitter.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-twitter"></i><span class="essbfc-followers-count">156k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-instagram"><a href="https://instagram.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-instagram"></i><span class="essbfc-followers-count">36.5k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-snapchat"><a href="https://onwardstate.com/2017/02/17/follow-along-with-onward-state-on-snapchat/" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-snapchat"></i><span class="essbfc-followers-count">10k</span><span class="essbfc-followers-text">Followers</span></div></a></li></ul></div>
</div>
</div><div id="ad_layers_ad_widget-13" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_ad_layers_ad_widget covered-target"><div id="div-gpt-ad-OS_ROS_Sidebar_Bottom" class="dfp-ad dfp-OS_ROS_Sidebar_Bottom" data-ad-unit="OS_ROS_Sidebar_Bottom">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_ROS_Sidebar_Bottom"); } );
						}
					</script>
</div></div><div id="mepr-account-links" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font MeprAccountCtrl_account_links_widget"><div class="terminal-card-title terminal-no-select terminal-sidebar-header-font">Account</div>
<ul id="mepr-logged-out-widget">
<li><a href="https://onwardstate.com/login/">Login</a></li>
</ul>
</div><div id="terminal-author-widget-5" class="terminal-sidebar-card terminal-card terminal-card-single terminal-utility-font widget_terminal-author-widget"><div class="terminal-card-title terminal-no-select terminal-sidebar-header-font"> Other posts by Gabe </div>
<div class="terminal-post-widget terminal-card-text terminal-post-widget-featured">
<div class="terminal-image">
<a href="https://onwardstate.com/2019/12/28/saquon-barkley-robbie-gould-pick-up-nfl-players-of-the-week-honors-for-week-16/" rel="bookmark" title="Saquon Barkley, Robbie Gould Pick Up Week 16 NFL Player Of The Week Honors">
<noscript><IMG width="500" height="334" src="https://i0.wp.com/images.onwardstate.com/uploads/2017/10/MattS-0425-e1508949041910.jpg?fit=500%2C334&amp;ssl=1" class="attachment-terminal-uncut-thumbnail size-terminal-uncut-thumbnail wp-post-image" alt="" title="Saquon Barkley, Robbie Gould Pick Up Week 16 NFL Player Of The Week Honors"></noscript>
<img width="500" height="334" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="attachment-terminal-uncut-thumbnail size-terminal-uncut-thumbnail wp-post-image lazyload" alt="" title="Saquon Barkley, Robbie Gould Pick Up Week 16 NFL Player Of The Week Honors" data-src="https://i0.wp.com/images.onwardstate.com/uploads/2017/10/MattS-0425-e1508949041910.jpg?fit=500%2C334&amp;ssl=1">
</a>
</div>
<h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/28/saquon-barkley-robbie-gould-pick-up-nfl-players-of-the-week-honors-for-week-16/" class="terminal-link-gray">
Saquon Barkley, Robbie Gould Pick Up Week 16 NFL Player Of The Week Honors </a>
</h4>
<div class="terminal-body-font terminal-text-gray">
<input type="hidden" value="" data-essbisPostContainer="" data-essbisPostUrl="https://onwardstate.com/2019/12/28/saquon-barkley-robbie-gould-pick-up-nfl-players-of-the-week-honors-for-week-16/" data-essbisPostTitle="Saquon Barkley, Robbie Gould Pick Up Week 16 NFL Player Of The Week Honors" data-essbisHoverContainer=""><p>Saquon Barkley and Robbie Gould earned recognition for continuing their impressive seasons in the NFL.</p>
</div>
</div>
<div class="terminal-post-widget terminal-card-text">
<h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/16/micah-parsons-named-espn-associated-press-all-american/" class="terminal-link-gray">
Micah Parsons Named ESPN, Associated Press All-American </a>
</h4>
</div>
<div class="terminal-post-widget terminal-card-text">
<h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/11/rankpennstatebasketball-climbin-in-popularity-on-twitter/" class="terminal-link-gray">
Movement To #RankPennStateBasketball Climbin&#8217; In Popularity On Twitter </a>
</h4>
</div>
</div></div>
<div id="terminal-hero-post-400489" class=" terminal-hero-widget terminal-card terminal-card-featured terminal-card-single terminal-alignment-center" data-terminal-post-id="400489" data-terminal-has-image="1" data-terminal-author="owenabbey" data-terminal-title="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" data-terminal-view="hero">
<div class="terminal-card-image">
<a id="terminal-hero-image-400489" href="https://onwardstate.com/2019/12/30/penn-state-womens-soccers-ali-krieger-marries-fellow-uswnt-star-ashlyn-harris/" class="terminal-limit-max-content-width  bookmark" title="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" data-terminal-post-id="400489" data-terminal-view="hero image" data-terminal-title="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris">
<noscript><IMG width="1000" height="500" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1000%2C500&amp;ssl=1" class="attachment-terminal-thumbnail-extra-large size-terminal-thumbnail-extra-large wp-post-image" alt="" title="Penn State Women’s Soccer’s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" srcset="https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1000%2C500&amp;ssl=1 1000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1024%2C512&amp;ssl=1 1024w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?zoom=2&amp;resize=1000%2C500&amp;ssl=1 2000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?zoom=3&amp;resize=1000%2C500&amp;ssl=1 3000w" sizes="(max-width: 1000px) 100vw, 1000px"></noscript>
<img width="1000" height="500" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="attachment-terminal-thumbnail-extra-large size-terminal-thumbnail-extra-large wp-post-image lazyload" alt="" title="Penn State Women’s Soccer’s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 1000w" sizes="(max-width: 1000px) 100vw, 1000px" data-srcset="https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1000%2C500&amp;ssl=1 1000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1024%2C512&amp;ssl=1 1024w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?zoom=2&amp;resize=1000%2C500&amp;ssl=1 2000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?zoom=3&amp;resize=1000%2C500&amp;ssl=1 3000w" data-src="https://i1.wp.com/images.onwardstate.com/uploads/2019/10/Ali-Krieger-6.jpg?resize=1000%2C500&amp;ssl=1">
</a>
</div>
<h1 class="terminal-headline-featured-font terminal-limit-max-content-width">
<a id="hero-title-400489" href="https://onwardstate.com/2019/12/30/penn-state-womens-soccers-ali-krieger-marries-fellow-uswnt-star-ashlyn-harris/" class="terminal-link-gray " title="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" data-terminal-post-id="400489" data-terminal-view="hero title" data-terminal-title="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris"> Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris </a>
</h1>
<div class="terminal-limit-max-content-width terminal-card-text terminal-body-font terminal-text-gray">
<input type="hidden" value="" data-essbisPostContainer="" data-essbisPostUrl="https://onwardstate.com/2019/12/30/penn-state-womens-soccers-ali-krieger-marries-fellow-uswnt-star-ashlyn-harris/" data-essbisPostTitle="Penn State Women&#8217;s Soccer&#8217;s Ali Krieger Marries Fellow USWNT Star Ashlyn Harris" data-essbisHoverContainer=""><p>Penn State soccer star Ali Krieger and fellow US Women&#8217;s National Teammate Ashlyn Harris got married Saturday in Miami</p>
</div>
<div class="terminal-card-fade"></div></div>
<div id="terminal-hero-post-400506" class=" terminal-hero-widget terminal-card terminal-card-featured terminal-card-double terminal-alignment-center" data-terminal-post-id="400506" data-terminal-has-image="1" data-terminal-author="mattdisanto" data-terminal-title="Ice God Jake Zembiec Shaves Iconic Mustache" data-terminal-view="hero">
<div class="terminal-card-image">
<a id="terminal-hero-image-400506" href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/" class="terminal-limit-max-content-width  bookmark" title="Ice God Jake Zembiec Shaves Iconic Mustache" data-terminal-post-id="400506" data-terminal-view="hero image" data-terminal-title="Ice God Jake Zembiec Shaves Iconic Mustache">
<noscript><IMG width="1000" height="500" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1000%2C500&amp;ssl=1" class="attachment-terminal-thumbnail-extra-large size-terminal-thumbnail-extra-large wp-post-image" alt="" title="Ice God Jake Zembiec Shaves Iconic Mustache" srcset="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1000%2C500&amp;ssl=1 1000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1024%2C512&amp;ssl=1 1024w" sizes="(max-width: 1000px) 100vw, 1000px"></noscript>
<img width="1000" height="500" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="attachment-terminal-thumbnail-extra-large size-terminal-thumbnail-extra-large wp-post-image lazyload" alt="" title="Ice God Jake Zembiec Shaves Iconic Mustache" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 1000w" sizes="(max-width: 1000px) 100vw, 1000px" data-srcset="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1000%2C500&amp;ssl=1 1000w, https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1024%2C512&amp;ssl=1 1024w" data-src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?resize=1000%2C500&amp;ssl=1">
</a>
</div>
<h1 class="terminal-headline-featured-font terminal-limit-max-content-width">
<a id="hero-title-400506" href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/" class="terminal-link-gray " title="Ice God Jake Zembiec Shaves Iconic Mustache" data-terminal-post-id="400506" data-terminal-view="hero title" data-terminal-title="Ice God Jake Zembiec Shaves Iconic Mustache"> Ice God Jake Zembiec Shaves Iconic Mustache </a>
</h1>
<div class="terminal-limit-max-content-width terminal-card-text terminal-body-font terminal-text-gray">
<input type="hidden" value="" data-essbisPostContainer="" data-essbisPostUrl="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/" data-essbisPostTitle="Ice God Jake Zembiec Shaves Iconic Mustache" data-essbisHoverContainer=""><p>&#8220;Just like our season, all good things have to come to an end eventually.&#8221;</p>
</div>
<div class="terminal-card-fade"></div></div>
<div id="terminal-popular" class="terminal-popular-container terminal-hidden-no-js">
<div class="terminal-header terminal-header-font"><h2><a id="terminal-popular" name="popular">Trending</a></h2></div> <div class="terminal-card terminal-card-featured terminal-card-single terminal-alignment-center">
<div class="terminal-card-title terminal-card-title-popular terminal-sidebar-header-font">
<select class="terminal-popular-select-filter" name="filter">
<option value="past-day">Past Day</option>
<option selected="selected" value="past-two-days">Past 48 Hours</option>
<option value="past-week">Past Week</option>
<option value="past-month">Past Month</option>
</select>
</div>
<div data-value="past-day" class="terminal-card-text terminal-popular-list terminal-popular-list-day terminal-hidden"><div class="terminal-popular-list-item " data-rank="1"><a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh" src="https://i1.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Maryland-0765.jpg?fit=500%2C330&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-link-gray">Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Mikey Mandarino	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="2"><a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Ice God Jake Zembiec Shaves Iconic Mustache" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?fit=500%2C461&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-link-gray">Ice God Jake Zembiec Shaves Iconic Mustache</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Matt DiSanto	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="3"><a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10" src="https://i2.wp.com/images.onwardstate.com/uploads/2019/12/Shannon-Soboslay-Cotton-Bowl-Penn-State-Vs-Memphis-5974-scaled.jpg?fit=500%2C322&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-link-gray">Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Owen Abbey	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="4"><a href="https://onwardstate.com/2019/12/28/micah-parsons-puts-entire-country-on-notice-with-impressive-cotton-bowl-performance/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Micah Parsons Puts Entire Country On Notice With Impressive Cotton Bowl Performance" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Shannon-Soboslay-Cotton-Bowl-Penn-State-Vs-Memphis-6051-1-scaled.jpg?fit=500%2C352&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/28/micah-parsons-puts-entire-country-on-notice-with-impressive-cotton-bowl-performance/?itm_source=parsely-api" class="terminal-link-gray">Micah Parsons Puts Entire Country On Notice With Impressive Cotton Bowl Performance</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Will Pegler	</div>
</div>
</div></div><div data-value="past-two-days" class="terminal-card-text terminal-popular-list terminal-popular-list-two-days"><div class="terminal-popular-list-item " data-rank="1"><a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh" src="https://i1.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Maryland-0765.jpg?fit=500%2C330&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-link-gray">Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Mikey Mandarino	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="2"><a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Ice God Jake Zembiec Shaves Iconic Mustache" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?fit=500%2C461&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-link-gray">Ice God Jake Zembiec Shaves Iconic Mustache</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Matt DiSanto	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="3"><a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10" src="https://i2.wp.com/images.onwardstate.com/uploads/2019/12/Shannon-Soboslay-Cotton-Bowl-Penn-State-Vs-Memphis-5974-scaled.jpg?fit=500%2C322&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-link-gray">Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Owen Abbey	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="4"><a href="https://onwardstate.com/2019/12/28/penn-state-football-leaves-lasting-legacy-foundation-for-future-success-after-cotton-bowl-victory/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Penn State Football Leaves Lasting Legacy, Foundation For Future Success After Cotton Bowl Victory" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Matt-Sniegowski-Cotton-Bowl-Football-vs-Memphis-0699-scaled.jpg?fit=500%2C344&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/28/penn-state-football-leaves-lasting-legacy-foundation-for-future-success-after-cotton-bowl-victory/?itm_source=parsely-api" class="terminal-link-gray">Penn State Football Leaves Lasting Legacy, Foundation For Future Success After Cotton Bowl Victory</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
 By Mikey Mandarino	</div>
</div>
</div></div><div data-value="past-week" class="terminal-card-text terminal-popular-list terminal-popular-list-week terminal-hidden"><div class="terminal-popular-list-item " data-rank="1"><a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh" src="https://i1.wp.com/images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Maryland-0765.jpg?fit=500%2C330&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/trace-mcsorley-makes-nfl-debut-in-baltimore-ravens-week-17-game-against-pittsburgh/?itm_source=parsely-api" class="terminal-link-gray">Trace McSorley Makes NFL Debut In Baltimore Ravens’ Week 17 Game Against Pittsburgh</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Mikey Mandarino	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="2"><a href="https://onwardstate.com/2019/12/26/penn-state-hires-minnesotas-kirk-ciarrocca-as-offensive-coordinator/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Penn State Hires Minnesota’s Kirk Ciarrocca As Offensive Coordinator" src="https://i2.wp.com/images.onwardstate.com/uploads/2019/12/DSC_2470-scaled.jpg?fit=500%2C297&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/26/penn-state-hires-minnesotas-kirk-ciarrocca-as-offensive-coordinator/?itm_source=parsely-api" class="terminal-link-gray">Penn State Hires Minnesota’s Kirk Ciarrocca As Offensive Coordinator</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Anthony Colucci	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="3"><a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Ice God Jake Zembiec Shaves Iconic Mustache" src="https://i1.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-29-at-5.07.44-PM.png?fit=500%2C461&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/ice-god-jake-zembiec-shaves-iconic-mustache/?itm_source=parsely-api" class="terminal-link-gray">Ice God Jake Zembiec Shaves Iconic Mustache</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Matt DiSanto	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="4"><a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10" src="https://i2.wp.com/images.onwardstate.com/uploads/2019/12/Shannon-Soboslay-Cotton-Bowl-Penn-State-Vs-Memphis-5974-scaled.jpg?fit=500%2C322&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/29/journey-browns-epic-touchdown-no-5-play-on-sportscenter-top-10/?itm_source=parsely-api" class="terminal-link-gray">Journey Brown’s Epic Touchdown No. 5 Play On SportsCenter Top 10</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Owen Abbey	</div>
</div>
</div></div><div data-value="past-month" class="terminal-card-text terminal-popular-list terminal-popular-list-month terminal-hidden"><div class="terminal-popular-list-item " data-rank="1"><a href="https://onwardstate.com/2019/12/17/latest-family-guy-episode-peter-griffin-played-football-at-penn-state/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Latest ‘Family Guy’ Episode: Peter Griffin Played Football At Penn State" src="https://i0.wp.com/images.onwardstate.com/uploads/2019/12/Screen-Shot-2019-12-17-at-1.09.46-PM.png?fit=500%2C248&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/17/latest-family-guy-episode-peter-griffin-played-football-at-penn-state/?itm_source=parsely-api" class="terminal-link-gray">Latest ‘Family Guy’ Episode: Peter Griffin Played Football At Penn State</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Anthony Colucci	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="2"><a href="https://onwardstate.com/2019/12/05/staff-predictions-penn-state-footballs-bowl-destination/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Staff Predictions: Penn State Football’s Bowl Destination" src="https://i2.wp.com/images.onwardstate.com/uploads/2019/11/AlexBauer-9281.jpg?fit=500%2C333&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/05/staff-predictions-penn-state-footballs-bowl-destination/?itm_source=parsely-api" class="terminal-link-gray">Staff Predictions: Penn State Football’s Bowl Destination</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Staff	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="3"><a href="https://onwardstate.com/2019/12/10/four-potential-offensive-coordinator-replacements-for-ricky-rahne/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Four Potential Offensive Coordinator Replacements For Ricky Rahne" src="https://i0.wp.com/images.onwardstate.com/uploads/2019/12/DSC_1295-scaled.jpg?fit=500%2C314&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/10/four-potential-offensive-coordinator-replacements-for-ricky-rahne/?itm_source=parsely-api" class="terminal-link-gray">Four Potential Offensive Coordinator Replacements For Ricky Rahne</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Mikey Mandarino	</div>
</div>
</div><div class="terminal-popular-list-item " data-rank="4"><a href="https://onwardstate.com/2019/12/08/penn-staters-weigh-in-on-cotton-bowl-berth-rose-bowl-snub/?itm_source=parsely-api" class="terminal-popular-list-item-image terminal-card-image"><img alt="Penn Staters Weigh In On Cotton Bowl Berth, Rose Bowl Snub" src="https://i0.wp.com/images.onwardstate.com/uploads/2019/12/Sean-Clifford-IL-scaled.jpg?fit=500%2C406&#038;ssl=1" /></a> <h4 class="terminal-headline-font">
<a href="https://onwardstate.com/2019/12/08/penn-staters-weigh-in-on-cotton-bowl-berth-rose-bowl-snub/?itm_source=parsely-api" class="terminal-link-gray">Penn Staters Weigh In On Cotton Bowl Berth, Rose Bowl Snub</a> </h4>
<div class="terminal-byline terminal-text-gray">
<div class="terminal-author terminal-no-select">
By Jim Davidson	</div>
</div>
</div></div> </div>
</div></div>
<div class="terminal-footer terminal-footer-font">
<div class="terminal-footer-inside">
<div class="terminal-footer-leaderboard">
<div class="terminal-limit-max-content-width-add-margin terminal-alignment-center"><div id="ad_layers_ad_widget-15" class="terminal-footer-section widget_ad_layers_ad_widget covered-target"><div id="div-gpt-ad-OS_leaderboard_Bottom" class="dfp-ad dfp-OS_leaderboard_Bottom" data-ad-unit="OS_leaderboard_Bottom">
<script type="text/javascript">
						if ( "undefined" !== typeof googletag ) {
							googletag.cmd.push( function() { googletag.display("div-gpt-ad-OS_leaderboard_Bottom"); } );
						}
					</script>
</div></div><div id="text-37" class="terminal-footer-section widget_text"> <div class="textwidget"><div class="essbfc-container essbfc-col-2 essbfc-template-tinygrey essbfc-nospace essbfc-notextvalue"><ul><li class="essbfc-facebook"><a href="https://www.facebook.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-facebook"></i><span class="essbfc-followers-count">113k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-twitter"><a href="https://www.twitter.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-twitter"></i><span class="essbfc-followers-count">156k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-instagram"><a href="https://instagram.com/onwardstate" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-instagram"></i><span class="essbfc-followers-count">36.5k</span><span class="essbfc-followers-text">Followers</span></div></a></li><li class="essbfc-snapchat"><a href="https://onwardstate.com/2017/02/17/follow-along-with-onward-state-on-snapchat/" target="_blank" rel="nofollow noopener noreferrer"><div class="essbfc-network"><i class="essbfc-icon essbfc-icon-snapchat"></i><span class="essbfc-followers-count">10k</span><span class="essbfc-followers-text">Followers</span></div></a></li></ul></div>
</div>
</div></div> </div>
<div class="terminal-footer-spread">
<div class="terminal-menu-footer">
<div class="menu-footer-container"><ul id="terminal-menu-footer" class="menu"><li id="menu-item-89496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89496"><a href="https://onwardstate.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-89497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89497"><a href="https://onwardstate.com/report-copyright-infringement/">Report Copyright Infringement</a></li>
</ul></div> </div>
<div class="terminal-copyright">
<p>&copy;&nbsp;
2008 - 2019 <span class="terminal-footer-title">Onward State</span></p>
</div>
</div>
</div>
</div>
<div class="essb_bottombar"><div class="essb_bottombar_inner"><div class="essb_bottombar_inner_buttons essb_bar_withoutcontent essb_bottombar_align_center"><div class="essb_links essb_counters essb_displayed_bottombar essb_share essb_template_tiny-retina essb_713353446 essb_width_flex essb_links_center print-no" id="essb_displayed_bottombar_713353446" data-essb-postid="400520" data-essb-position="bottombar" data-essb-button-style="button" data-essb-template="tiny-retina" data-essb-counter-pos="inside" data-essb-url="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" data-essb-twitter-url="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" data-essb-instance="713353446"><ul class="essb_links_list"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/dialog/feed?app_id=262823580468325&amp;display=popup&amp;name=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&picture=https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg&description=Trace McSorley\&%23039;s NFL debut headlines this week\&%23039;s edition of Nittany Lions in the NFL." title="" onclick="essb.window(&#39;https://www.facebook.com/dialog/feed?app_id=262823580468325&amp;display=popup&amp;name=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&picture=https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg&description=Trace McSorley\&%23039;s NFL debut headlines this week\&%23039;s edition of Nittany Lions in the NFL.&#39;,&#39;facebook_advanced&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;counturl=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;related=OnwardState&amp;via=OnwardState&#39;,&#39;twitter&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_more nolightbox"> <a href="#" title="" onclick="essb.toggle_more_popup(&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_more"></span><span class="essb_network_name essb_noname"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox essb_after_more"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&#39;,&#39;linkedin&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_print nolightbox essb_after_more"> <a href="https://www.printfriendly.com/print/?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.window(&#39;http://www.printfriendly.com/print/?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&#39;,&#39;print_friendly&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_reddit nolightbox essb_after_more"> <a href="https://reddit.com/submit?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&#39;,&#39;reddit&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_pinterest nolightbox essb_after_more"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_pocket nolightbox essb_after_more"> <a href="https://getpocket.com/save?title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F" title="" onclick="essb.window(&#39;https://getpocket.com/save?title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F&#39;,&#39;pocket&#39;,&#39;713353446&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pocket"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_messenger nolightbox essb_after_more"> <a href="fb-messenger://share/?link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.fbmessenger('262823580468325', 'https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/', '713353446'); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name"><span class="essb_counter_inside" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_totalcount_item" style="display: none !important;" data-essb-hide-till="1" data-counter-pos="inside"><span class="essb_totalcount essb_t_r_big " title="" data-shares-text="total shares"><span class="essb_t_nb">0<span class="essb_t_nb_after">total shares</span></span></span></li></ul></div><div class="essb_morepopup essb_morepopup_713353446 essb_morepopup_bottombar essb_morepopup_modern" style="display:none;"> <a href="#" class="essb_morepopup_close" onclick="essb.toggle_less_popup('713353446'); return false;"><i class="essb_icon_close"></i></a> <div class="essb_morepopup_content essb_morepopup_content_713353446"><div class="essb-morepopup-modern-message"><div class="essb-morepopup-modern-title">Nittany Lions In The NFL: Week 17 Roundup</div><div class="essb-morepopup-modern-link"><a href="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" target="_blank">https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/</a></div></div><div class="essb_links essb_displayed_more_popup essb_share essb_template_jumbo-retina essb_1355135616 essb_width_columns_4 essb_network_align_center essb_links_center print-no" id="essb_displayed_more_popup_1355135616" data-essb-postid="400520" data-essb-position="more_popup" data-essb-button-style="vertical" data-essb-template="jumbo-retina" data-essb-counter-pos="left" data-essb-url="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" data-essb-twitter-url="https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" data-essb-instance="1355135616"><ul class="essb_links_list essb_vertical_name"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/dialog/feed?app_id=262823580468325&amp;display=popup&amp;name=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&picture=https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg&description=Trace McSorley\&%23039;s NFL debut headlines this week\&%23039;s edition of Nittany Lions in the NFL." title="" onclick="essb.window(&#39;https://www.facebook.com/dialog/feed?app_id=262823580468325&amp;display=popup&amp;name=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&picture=https://images.onwardstate.com/uploads/2018/11/Matt-Sniegowski-Football-vs-Ohio-State-White-Out-2018-Trace-McSorley-2.jpg&description=Trace McSorley\&%23039;s NFL debut headlines this week\&%23039;s edition of Nittany Lions in the NFL.&#39;,&#39;facebook_advanced&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook</span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;counturl=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;related=OnwardState&amp;via=OnwardState&#39;,&#39;twitter&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter</span></a></li><li class="essb_item essb_link_pinterest nolightbox"> <a href="#" title="" onclick="essb.pinterest_picker(&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pinterest"></span><span class="essb_network_name">Pinterest</span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&amp;url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&#39;,&#39;linkedin&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn</span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="https://www.printfriendly.com/print/?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.window(&#39;http://www.printfriendly.com/print/?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&#39;,&#39;print_friendly&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print</span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email</span></a></li><li class="essb_item essb_link_reddit nolightbox"> <a href="https://reddit.com/submit?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup" title="" onclick="essb.window(&#39;http://reddit.com/submit?url=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/&amp;title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&#39;,&#39;reddit&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_reddit"></span><span class="essb_network_name">Reddit</span></a></li><li class="essb_item essb_link_pocket nolightbox"> <a href="https://getpocket.com/save?title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F" title="" onclick="essb.window(&#39;https://getpocket.com/save?title=Nittany+Lions+In+The+NFL%3A+Week+17+Roundup&url=https%3A%2F%2Fonwardstate.com%2F2019%2F12%2F30%2Fnittany-lions-in-the-nfl-week-17-roundup%2F&#39;,&#39;pocket&#39;,&#39;1355135616&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_pocket"></span><span class="essb_network_name">Pocket</span></a></li><li class="essb_item essb_link_messenger nolightbox"> <a href="fb-messenger://share/?link=https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/" title="" onclick="essb.fbmessenger('262823580468325', 'https://onwardstate.com/2019/12/30/nittany-lions-in-the-nfl-week-17-roundup/', '1355135616'); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_messenger"></span><span class="essb_network_name">Facebook Messenger</span></a></li></ul></div></div></div> <div class="essb_morepopup_shadow essb_morepopup_shadow_713353446 essb_morepopup_shadow_modern" onclick="essb.toggle_less_popup('713353446'); return false;"></div></div></div></div>

<script data-cfasync="false">

		function uuidProfileCall() {
			var rootUrl = 'https://api.parsely.com/v2/profile?apikey=onwardstate.com';
			var uuid = '&uuid=' + PARSELY.config.parsely_site_uuid;
			var requestUrl = rootUrl + uuid + '&url=' + window.location.href;
			jQuery.ajax({
				url: requestUrl,
				dataType: "jsonp"
			});
		}

		if (typeof PARSELY == 'object') {
			var oldonload = PARSELY.onload;
			if (typeof PARSELY.onload != 'function') {
				PARSELY.onload = uuidProfileCall
			}
			else {
				PARSELY.onload = function () {
					if (oldonload) {
						oldonload();
					}
					uuidProfileCall();
				};
			}
		}

		else {
			PARSELY = {
				onload: uuidProfileCall
			}
		}
	</script>
<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="onwardstate.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="x7pk3l1s4jcxyxiiwh6v" data-user="44486"></script><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="ykr0bwlkaheq1bhzjba2" data-user="44486"></script><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="m1knqziobomegqrmd7y8" data-user="44486"></script><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="cwqhqknpi7uvtp0qe75u" data-user="44486"></script><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="w8pd16pz8uoxkzjawvgf" data-user="44486"></script><div id="om-vkorkrz3blzt6wn4b3so-holder"></div><script>var vkorkrz3blzt6wn4b3so,vkorkrz3blzt6wn4b3so_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){vkorkrz3blzt6wn4b3so_poll(function(){if(window['om_loaded']){if(!vkorkrz3blzt6wn4b3so){vkorkrz3blzt6wn4b3so=new OptinMonsterApp();return vkorkrz3blzt6wn4b3so.init({"u":"44486.799955","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.opmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;vkorkrz3blzt6wn4b3so=new OptinMonsterApp();vkorkrz3blzt6wn4b3so.init({"u":"44486.799955","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script> <script type="text/javascript">var x7pk3l1s4jcxyxiiwh6v_shortcode = true;var ykr0bwlkaheq1bhzjba2_shortcode = true;var m1knqziobomegqrmd7y8_shortcode = true;var cwqhqknpi7uvtp0qe75u_shortcode = true;var w8pd16pz8uoxkzjawvgf_shortcode = true;var vkorkrz3blzt6wn4b3so_shortcode = true;</script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/js/slick.min.js?ver=20170328'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/js/tooltipster.min.js?ver=20170328'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/js/jquery.isotope.min.js?ver=20170328'></script>
<script type='text/javascript' src='https://onwardstate.com/wp/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://onwardstate.com/wp/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://onwardstate.com/wp/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/logo-carousel-pro/assets/js/scripts.js?ver=20170328'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/lib/modules/social-image-share/assets/js/easy-social-image-share.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/lazy-loading-responsive-images/js/lazysizes.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/lazy-loading-responsive-images/js/ls.unveilhooks.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://onwardstate.com//wp-content/plugins/optinmonster/assets/js/helper.js?ver=1.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201901.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'31617667',post:'400520',tz:'-5',srv:'onwardstate.com'} ]);
	_stq.push([ 'clickTrackerInit', '31617667', '400520' ]);
</script>
<div class="essb_mailform"><div class="essb_mailform_content"><p>Send this to a friend</p><label class="essb_mailform_content_label">Your email</label><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email" /><label class="essb_mailform_content_label">Recipient email</label><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email" /><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="1485938427" /><input type="hidden" id="essb_mail_instance" value="" /><input type="hidden" id="essb_mail_post" value="" /></div></div><div class="essb_mailform_shadow"></div><link rel="stylesheet" id="essb-social-image-share" href="https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/lib/modules/social-image-share/assets/css/easy-social-image-share.min.css" type="text/css" media="all" /><link rel="stylesheet" id="essb-cct-style" href="https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/lib/modules/click-to-tweet/assets/css/styles.min.css" type="text/css" media="all" /><script type="text/javascript">
				(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async=true;;
				po.src = 'https://onwardstate.com//wp-content/plugins/easy-social-share-buttons3/assets/js/essb-core.min.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		})();</script><script type="text/javascript">var essb_mailform_opened = false; function essb_open_mailform(unique_id) { jQuery.fn.extend({ center: function () { return this.each(function() { var top = (jQuery(window).height() - jQuery(this).outerHeight()) / 2; var left = (jQuery(window).width() - jQuery(this).outerWidth()) / 2; jQuery(this).css({position:'fixed', margin:0, top: (top > 0 ? top : 0)+'px', left: (left > 0 ? left : 0)+'px'}); }); } }); if (essb_mailform_opened) { essb_close_mailform(unique_id); return; } var sender_element = jQuery(".essb_"+unique_id); if (!sender_element.length) return; var sender_post_id = jQuery(sender_element).attr("data-essb-postid") || ""; jQuery("#essb_mail_instance").val(unique_id); jQuery("#essb_mail_post").val(sender_post_id); var win_width = jQuery( window ).width(); var win_height = jQuery(window).height(); var doc_height = jQuery('document').height(); var base_width = 300; if (win_width < base_width) { base_width = win_width - 30; } var height_correction = 20; var element_class = ".essb_mailform"; var element_class_shadow = ".essb_mailform_shadow"; jQuery(element_class).css( { width: base_width+'px'}); var popup_height = jQuery(element_class).outerHeight(); if (popup_height > (win_height - 30)) { jQuery(element_class).css( { height: (win_height - height_correction)+'px'}); } jQuery("#essb_mailform_from").val(""); jQuery("#essb_mailform_to").val(""); if (jQuery("#essb_mailform_c").length) jQuery("#essb_mailform_c").val(""); jQuery(element_class_shadow).css( { height: (win_height)+'px'}); jQuery(element_class).center(); jQuery(element_class).slideDown(200); jQuery(element_class_shadow).fadeIn(200); essb_mailform_opened = true; essb.tracking_only("", "mail", unique_id); }; function essb_close_mailform() { var element_class = ".essb_mailform"; var element_class_shadow = ".essb_mailform_shadow"; jQuery(element_class).fadeOut(200); jQuery(element_class_shadow).fadeOut(200); essb_mailform_opened = false; }; function essb_mailform_send() { var sender_email = jQuery("#essb_mailform_from").val(); var recepient_email = jQuery("#essb_mailform_to").val(); var captcha_validate = jQuery("#essb_mailform_c").length ? true : false; var captcha = captcha_validate ? jQuery("#essb_mailform_c").val() : ""; var custom_message = jQuery("#essb_mailform_custom").length ? jQuery("#essb_mailform_custom").val() : ""; if (sender_email == "" || recepient_email == "" || (captcha == "" && captcha_validate)) { alert("Please fill all fields in form"); return; } var mail_salt = jQuery("#essb_mail_salt").val(); var instance_post_id = jQuery("#essb_mail_post").val(); console.log("mail salt = " + mail_salt); if (typeof(essb_settings) != "undefined") { jQuery.post(essb_settings.ajax_url, { "action": "essb_mail_action", "post_id": instance_post_id, "from": sender_email, "to": recepient_email, "c": captcha, "cu": custom_message, "salt": mail_salt, "nonce": essb_settings.essb3_nonce }, function (data) { if (data) { console.log(data); alert(data["message"]); if (data["code"] == "1") essb_close_mailform(); }},'json'); } };</script> <script type="text/javascript">var omapi_localized = { ajax: 'https://onwardstate.com/wp/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: 'ff4bba416b', slugs: {"x7pk3l1s4jcxyxiiwh6v":{"slug":"x7pk3l1s4jcxyxiiwh6v","mailpoet":false},"ykr0bwlkaheq1bhzjba2":{"slug":"ykr0bwlkaheq1bhzjba2","mailpoet":false},"m1knqziobomegqrmd7y8":{"slug":"m1knqziobomegqrmd7y8","mailpoet":false},"cwqhqknpi7uvtp0qe75u":{"slug":"cwqhqknpi7uvtp0qe75u","mailpoet":false},"w8pd16pz8uoxkzjawvgf":{"slug":"w8pd16pz8uoxkzjawvgf","mailpoet":false},"vkorkrz3blzt6wn4b3so":{"slug":"vkorkrz3blzt6wn4b3so","mailpoet":false}} };</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":400520,"object_key":"post","object_type":"post","term_ids":[23282]};</script>
</body>
</html>
